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Xerte Online Toolkits 
Before you begin… 

 
1. Download the “xerte media resources” from Learning Central and save to your desktop. Unzip the folder. 
2. Open a browser (Firefox and Chrome are recommended for Xerte Online Toolkits). 
3. Allow popups for xerte.cardiff.ac.uk. See instructions for both Firefox and Chrome browsers below. 

Firefox 

 

! 

Click on “Tools” then “Options” 1 

Click on “Allow” 
5 

Click on “Content” 

2 

Click on “Exceptions” 
3 

Enter this address 
4 

Click on “Close” then “OK” 
5 

© Samantha Barrington (2013). All Rights Reserved. 
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Chrome 

1. Click the on the browser toolbar. 
2. Select Settings. 
3. Scroll to the bottom and click “+ Show advanced settings”. 
4. In the "Privacy" section, click the “Content settings” button. 
5. In the "Pop-ups" section, click “Manage exceptions”. 

 

 
 

6. Click “Done” on the Content Settings window. 
7. Exit the settings page by clicking the “X” in the tab.  

Click on “Done” 
7 

Enter this address 
6 
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Logging into XOT at Cardiff 
 
Enter xerte.cardiff.ac.uk into your browser. 
 

 
 
 
  
 

1 

Log in with your Cardiff 
username and password 

2 
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Creating a Learning Object 
 

 
 
 
 
 
 
 
 

Click on “Create” 
1 



Xerte Online Toolkits: Getting Started Guide 
 

5 
 

 

 

Enter a name 
and click “Create 
Project” 

2 
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Add a title 
e.g. Driving Resource 
 
This will be displayed on 
the top of every page 

3 

Change to “Fill 
Window” 

This will scale the 
screen size to fill the 
window 

Click on 
“Publish” to save 

5 

4 
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Create a Title Page 
 
          Click on the Insert menu. Select Insert > Text > Title Page 
 

 
 

 
 
  
 
          Click “Play” to preview your title page.  
 
 
NOTE: The “Play” and “Publish” buttons save your progress. You must save regularly! 
XOT can time out after a period of inactivity. 
 
 
  

1 

Enter a page title and title text. 
2 

3 
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Add a Background Image to the Title Page 
 

 

 

              You should then be presented with a pop up message confirming successful upload. Press “OK”. 

 

              Press “Play” to save and view a preview of the title page. 

 

 

Click on the drop down arrow in the Optional 
Properties field. 
Select “Background Image” 

1 

Click on “Add” 
2 

Click on the Import Media button and 
browse to the desktop. Select the image 
titled Speedometer.jpg. 

Note: This image has already been 
resized. However, when using XOT in your 
own context you should ensure images 
are resized to a maximum of 800 x 600 
pixels. Xerte supports .jpg .png and .gif file 
formats. 
 

3 

4 

5 
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NOTE: 
If you cannot see your image as displayed in the screenshot above, then you will need to manually add the image 
to the media library. You should not normally have to do this, but there seems to be an on campus issue with 
uploading images. Instructions on how to manually import images to the media library are available on page 32. 

The image has now been added to the 
title page. However, the title is no longer 
clearly visible. To overcome this you can 
fade the image. 
 
Close the preview window and return to 
the edit window. 
 

6 
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Click on the drop down arrow in the Optional 
Properties field. 
Select “Background Alpha” 

7 

Click on “Add” 
8 

Enter “20” and press “Play” to save and 
view the updated title page.  

When you have finished viewing this 
page, close the preview window to 
return to the edit window. 

9 
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Create a Plain Text Page 
 
          Click on the Insert menu. Select Text > Plain Text 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
  
  

Enter a page title and page text. 

Note: The page text can be 
copied from the document titled 
Page Text Content.txt in the 
resources folder. 

2 

1 
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          Click “Play” to preview your title page   
 
 

 

             Click here to go to the text page. 

          Close the window and return to the edit window. 
 
  

3 

4 



Xerte Online Toolkits: Getting Started Guide 
 

13 
 

Create a HotSpot Image Page 
 
A hotspot image page can be used by learners to navigate and explore an image e.g. a map, anatomical diagram, or a screenshot. 
 
Hotspot image pages have been developed with built-in accessibility features. For example, the user can fully navigate the image using a 
keyboard, which may be used by visually impaired users or users who have motor disabilities.1 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
                                                           
1 Further information about keyboard accessibility is available from Web Aim - http://webaim.org/techniques/keyboard.  

Click on the Insert menu. Select Interactivity > Hotspot Image 
1 

http://webaim.org/techniques/keyboard
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Enter a page title and page text. 
2 

Click on “New HotSpot” to add a 
hotspot to the image. 

6 

Click on the Import Media button and 
browse to the desktop. Select the image 
titled “Car Interior.jpg” 
 
You should then be presented with a pop up 
message confirming successful upload. 
Press “OK”.  
 
You may also need to manually upload the 
image to the image library – see page 32. 

3 

Check this box. 
4 

Add a brief description of the image. This is 
required to describe the image to visually 
impaired users. It will be displayed when 
the mouse pointer is hovered over the 
image and can be read by screen reader 
software. 

5 
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Enter a title for the hotspot. This should 
describe the highlighted section of the 
image e.g. clutch pedal. 

7 

Click on “Edit” to add the 
hotspot to the image. 

8 

Drag and resize the hotspot marker over the 
part of the image you wish to highlight. 

Press ‘Save’ and close the Image Inspector 
window. 

9 
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Enter text which will be displayed when 
the learner clicks on the hotspot.  In this 
case add a description of the clutch 
pedal. 

10 

Click “New Hotspot” and repeat steps 7-10 
to add hotspots for the following parts: 
brake pedal, accelerator pedal, gear stick 
and handbrake. 

11 
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          Click “Play” to preview your hotspot page   
 
 

 

 

          Close the window and return to the edit window. 
 
 
 
 

12 

13 

You will notice that the image also has these 
forward and back navigation buttons. These 
buttons are available when the 
“Interactivity” property is set to Show Me. 
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Publishing your Learning Resource: Web Link 
 
Currently your learning object is private (XOT default setting). You can change the setting to public to make it available to others, and embed or 
link to your object from another website or VLE. 
 
            If you are in the Editor Window, click “Publish” to save the latest changes. Then close the Editor Window to return to the homepage. 
 
 

 
 
 
 

Click on the name of your learning object 
once, to highlight it (as shown in the 
screenshot). 

Then click the “Properties” button.  

The Project Properties will then open in a new 
window. 

2 

1 
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Click on the 
“Access” tab 

3 
Tick the Public checkbox 

4 

Click “Change Access” to 
save your changes 

5 

This message will then be 
displayed to confirm the changes 
have been applied. 
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Click on the “Project” tab 
6 

Ensure that the “Javascript” option is checked for your 
object to be accessible from Apple mobile/tablet devices. 

7 

Copy the URL and paste it into a browser 
to view your object. 

8 

NOTE: You can also copy the embed code to 
embed it on a website (e.g. a blog) or on a VLE 
page. 
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Edit your LO: Add a Drag and Drop Activity – Formative Task 

You can continue to edit your learning object, even though your resource is now public. Go to the XOT homepage, and follow step 1 to open and 
re-edit your object. 
  

 
 
 
 
 

 

 

 

Click on the name of your learning object 
once, to highlight it (as shown in the 
screenshot). 

Then click the “Edit” button.  

The Edit Panel will then open in a new 
window as before. 

1 
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          In the Edit Panel, click on the Insert menu. Select Interactivity > Drag and Drop Labelling 
 
 

 

 

 

2 
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Enter a page title and text. 

The page text should include 
instructions on how to complete 
the task. 

3 

Click on “New HotSpot” to add a 
hotspot to the image. 

6 

Click on the Import Media button and 
browse to the desktop. Select the image 
titled “Car Interior.jpg” 
 
You should then be presented with a pop up 
message confirming successful upload. 
Press “OK”.  
 

4 

Add a brief description of the image, to be 
displayed as the tooltip text. 

5 
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Enter a title for the label. 
7 

Click on “Edit” to create a hotspot area on the 
image. This is where the user will attach the 
label, therefore the hotspot area needs to be big 
enough to accommodate the height of the label. 
However, the hotspot area can be narrower 
than the label width. 

See the screenshot on the following page. 

 

8 

Enter a message which will 
be displayed when the 
learner has attached the 
matching label. 

9 

Click “New Hotspot” and repeat steps 7-10 to add hotspots for the 
gear stick and handbrake. 

NOTE: Due to the size and position of the labels, it would not be 
possible in this case to add a label to the brake and accelerator 
pedals as they will be obscured by the label for the clutch pedal. 
Therefore images will need to be carefully selected for this activity 
to ensure it is large enough to accommodate the labels once they 
are in position. 

See the screenshot on the following page. 

10 
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Once you have finished adding the 
hotspots, click “Publish”. This will save 
your progress, and update your public 
learning object. 

11 

View your learning object by either: 
1. Clicking “Play” in the Edit Panel 
2. Pasting the URL into a browser 
3. Refreshing the page if your public 
learning object is already open. 
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Embed a YouTube Video in a Plain Text Page 
 
There is a YouTube Video page template available in XOT. However, when viewing the page some browsers will block the video, unless the user 
submits agreement for the video to load (as demonstrated in the image below). This can cause confusion and frustration for learners. However, 
videos can be embedded in the Plain Text template – the same template that we used to create the introductory page. This page will display the 
video without the express permission from the user (as long as the browser has the necessary plugins). 
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          In the Edit Panel, click on the Insert menu. Select Text > Plain Text 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

  

1 
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Enter a page title and page text. 
2 
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Click on “Embed” 
5 

In your browser enter the following YouTube 
address (you can copy this address from the 
YouTube Link.txt document in the resources folder). 

3 

Click on “Share” 
4 

Copy the embed code. 
6 
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NOTE: You should ensure that there is a 
text equivalent for multimedia content. You 
can add a transcript, or a link to a transcript 
to the “Page Text” area. 
 
Visit http://webaim.org/techniques/captions/ 
for further information. 

Paste the embed code, 
and click on “Publish” 
to save your changes. 

7 

http://webaim.org/techniques/captions/
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Importing Files to the Media Library 

  
 

            If you are in the Editor Window, click “Publish” to save the latest changes. Then close the Editor Window to return to the homepage. 
 
 

If you cannot see your image as displayed in this screenshot, then you will 
need to manually add the image to the media library. You should not 
normally have to do this, but there seems to be an on campus issue with 
uploading images. 

1 
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Click on the name of your learning object 
once, to highlight it (as shown in the 
screenshot). 

Then click the “Properties” button.  

The Project Properties will then open in a new 
window. 

2 

Click on the “Media 
and quota” tab 

3 

Click on the “Browse” button to select 
the image you wish to upload. 

4 
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The name of the image (you 
wish to import) should then 
be displayed next to the 
browse button. 

Click on the “Import” button. 

5 

You should then be 
presented with the 
following dialog box. 
Select “OK” 

6 
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You will then see the image listed in the media 
library. 

Close this window, and select “Edit” to 
continue editing your learning object. 


